78.5 F
Charlotte Amalie
Saturday, May 21, 2022
HomeNewsLocal newsOne Killed, One Injured in Crash on Queen Mary Car Highway

One Killed, One Injured in Crash on Queen Mary Car Highway

One man was killed and another seriously injured Sunday night when two cars collided on Queen Mary Highway in the vicinity of the old Brow Soda factory building.

According to the V.I. Police Department, the 911 emergency center received a call reporting the accident at 9:52 p.m. Sunday.

Traffic investigators said a Hispanic man was driving his pickup east, and a middle-aged black man in a compact sedan was traveling east bound in the west lane. The two vehicles collided in the west-bound lane, police said.

The driver of the compact was lifeless when officers arrived at the scene, the report said. The man was identified as 48-year-old Ira Williams. His body was transported to the Juan F. Luis Memorial Hospital, where he was pronounced dead.

Advertising (skip)
Advertising (skip)
Advertising (skip)
Advertising (skip)
Advertising (skip)

The 68-year-old male Hispanic driver was transported to the hospital. The victim was unable to give a statement due to his injuries, police said. 

Print Friendly, PDF & Email
Keeping our community informed is our top priority.
If you have a news tip to share, please call or text us at 340-228-8784.




Support local + independent journalism in the U.S. Virgin Islands

Unlike many news organizations, we haven't put up a paywall – we want to keep our journalism as accessible as we can. Our independent journalism costs time, money and hard work to keep you informed, but we do it because we believe that it matters. We know that informed communities are empowered ones. If you appreciate our reporting and want to help make our future more secure, please consider donating.



STAY CONNECTED

20,771FansLike
4,716FollowersFollow

FROM FACEBOOK

Comments Box SVG iconsUsed for the like, share, comment, and reaction icons
This message is only visible to admins.
Problem displaying Facebook posts.
Error: Server configuration issue